Overview
When email Alert settings configured to be sent via an SMTP relay server, Kerio Control may generate the following messages in the Error log:
Unable to get address where to send failure notification, message: ./mqueue/bc3a580b-6a9d-d441-b53c-6028176f8f43.eml,
retryNo: 0
The SMTP relay server is Kerio Connect located behind the Kerio Control firewall.
Diagnosis
Kerio Control is configured to send emails using the Kerio Connect mail server as an SMTP relay.
The Kerio Control Antivirus is configured to check SMTP inbound connections. For more information, please refer to Configuring Email Scanning in Kerio Control.
Because Kerio Connect is placed behind the Kerio Control firewall and Antivirus SMTP scanning is enabled, the SMTP messages cannot reach the target mailbox. Such configuration may generate a loop in checking and sending emails.
Solution
Disable SMTP scanning in Kerio Control -> Configuration -> Antivirus settings.
Confirmation
The error entry is no longer generated, the email notifications are sent successfully.