Overview
There are instances where due to the specific configuration setup, the following clickable warning is displayed when logging in to Kerio Control Webadmin:
Problem with default gateway
On clicking on the warning, the following notification appears:
Duplicate default gateway was detected
This article provides a resolution for this issue.
Information
Root Cause
This notification warning is shown when there is an existing duplicate route.
Process
Follow the steps below to resolve the issue:
- On your PC, which is hosting Kerio Control installation (in case of VMware installations), open CLI and run the command:
route delete x.x.x.x
where x.x.x.x is the IP address of the duplicate interface. - If there is no duplicate interface and Kerio Control is misinterpreting your Network setup, you can try to disable this notification by modifying the internal files:
-
Enable SSH by navigating to Kerio Control Webadmin > hold Shift button and click Open Status > System Health > Enable SSH > Yes > Ok
- Log in via SSH.
- For Windows User, use Putty client.
Username:root
Password: same as Admin user - For Linux/macOS, use the following command:
$ ssh root@ip_address_of_Control
- For Windows User, use Putty client.
- Navigate to the folder:
$ cd /opt/kerio/winroute/webadmin
- Modify notifications.js. Notification about Duplicate gateway is located at line 224. Either delete or comment this line.
line: 224:k_title: k_tr('Duplicate default gateway was detected', 'notifications')
- Restart Kerio Control using the command:
$ /etc/boxinit.d/60winroute restart
-
Enable SSH by navigating to Kerio Control Webadmin > hold Shift button and click Open Status > System Health > Enable SSH > Yes > Ok
[Note: It is recommended to make a copy of the original file before modifying it (the wrong correction can cause some issues with overall Notification functionality in Kerio Control)]
Confirmation
No warning is seen in Kerio Control Webadmin when logging in.